How can we improve Excel for iPad & iPhone (iOS)?

Excel iOS: auto-saves files despite having switched off auto-save

Please see https://answers.microsoft.com/thread/7768863c-337c-49a3-b207-1a9635510bad for a serious bug first reported by the OP over 4 months ago.

If auto-save is switched off (which I think it should be by default, but that's another matter) and I discard changes when exiting a file, the file timestamp still changes. This then spreads to other devices seeing the file on OneDrive. So if I just want to check something in a file from several years ago it suddenly looks like I've recently edited the file! This bug of course is not present in Windows.

3 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    James Schofield shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Agree. The many users I share a Dropbox folder with will be getting sick of me by now. It looks like I make changes to their files- even really old or important files that I'm not responsible for. We can't use the file date to manage our files at this rate.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I have this issue, but even worse: When I open Excel on my iPhone 6s it opens an old version of the file and overwrites the current version. It also turns auto-save back on every time I turn it off.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I agree. Just to clarify, it happens if you pick up an Excel from a cloud service using the iOS cloud document picker. The bug has not always been there and the Excel version of perhaps a year back does not have this auto-save bug. If you access an Excel file through the native cloud connection in Excel, the bug does not happen.

      Feedback and Knowledge Base