Feedback by UserVoice

How can we improve Excel for Mac?

Allow users to turn off cursor "glide" animation (cell selection animation)

l find the silly animation that "glides" the cursor from cell to cell to be distracting. That's bad. But the fact that there is no way to turn it off is absolutely infuriating. Let me turn it off.

958 votes
Sign in
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Rob shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
completed  ·  Dan Battagin [MS XL] responded  · 

Good morning (5 April, 2016),

I’m happy to be able to update that we’ve released an update for this issue in Mac Excel 15.21, which has rolled out to Office Insiders today and pending any blocking issues we find there should start rolling out to everyone in a week or so.

In order to turn off this animation once you have the updated build, you’ll want to go to Excel > Preferences > Edit and uncheck the “Provide feedback with animation” checkbox.

Hope that helps,
Dan [MS]


Greetings and happy Friday (2.26),

Good news – based on the feedback here, we’re going to hook up all of the new animations – including this cursor glide animation – to a setting in Excel > Preferences so that you can turn them off.

Dan [MS]


Sign in
Sign in with: facebook google
Signed in as (Sign out)
  • Anonymous commented  ·   ·  Flag as inappropriate

    I just updated excel- these animations are decorative and counterproductive-- using a spreadsheet is not entertainment. Ug. Would you do this on Bloomberrg??Never.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Got it, it can be turned off by going to "ease of access" in the "control" panel or "settings" in Windows. Turn off the "Show animations in windows"...worked on my version of windows 10.

  • Anonymous commented  ·   ·  Flag as inappropriate

    There is no professional in their right mind who has time to wait for their cursor to keep up with them. We move fast as we can go. If the program can't keep up, we get another program. No time for graphic displays, pop ups, garbage, and stuff to bog a program down. Don't care about whistles and bells, just get us to the next step as fast as possible in the easiest way possible. I can see that it may help someone who visually needs help, and that's understandable and great, but for the rest of us, you have to give us the option to be able to shut this off. There's no time for it. Have to move on to a version that allows me to move faster.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Seriously? It is 2018 and this is still an issue??????? We've known about this problem since 2015 and nothing has been done? Are you kidding me? THIS NEEDS TO BE FIXED. MS - Find a way to turn off the cell glide. PLEASE. This is nonsense. I selected "disable hardware graphics acceleration" I'm sure whatever that was was really distracting too, but this did not fix cell glide, even after I rebooted. I want to click on a cell, and instantly select that cell. I don't want to sit there and wait while I watch the box slide over in slow motion. I cannot express in words how distracting this is. WHO thought this would be a good idea and what are they using excel for? Arts and crafts?

  • leshinder commented  ·   ·  Flag as inappropriate

    Really annoying glide. Probably OK for non professional users but when you use it every day this is design over function. MS need to test their changes with professional users. When can this be disabled? Where can you change Excel preferences?

  • Mike Williams commented  ·   ·  Flag as inappropriate

    I found this to be working but only after I restarted my PC did I notice that the lagging/delayed response had stopped. Under File, Options, Advanced, Display, put a check in the Disable hardware graphics acceleration. Reboot PC.

  • Mike Williams commented  ·   ·  Flag as inappropriate

    Using Office 365 Pro Plus 2016 on my computer with dual screens and when moving an excel window from one screen to the next I get a lagging or delayed response. This only happens in excel with any size file. Any available solution for me. I have tried a few in this thread but none seems to be working.

  • anonymice commented  ·   ·  Flag as inappropriate

    Just showed up unannounced in all my Office programs about 2 weeks ago. Definitely super-annoying. At first I thought I had malware, that's how jacked up the cursor animation is. Thanks to all for the solutions.

  • Anon commented  ·   ·  Flag as inappropriate

    What on earth were Microsoft thinking??? This 'feature' is annoying as the Word paperclip from 20 years ago.

  • Oscar commented  ·   ·  Flag as inappropriate

    What is the BOTTOM LINE?? My excel screen keeps scrolling around and jumping sideways with NO provocation. Please tell me how to turn this off. Ideally with no chit chat.

  • Mike commented  ·   ·  Flag as inappropriate

    Whoever made the decision to add this pointless gliding "animation" doubtfully actually uses Excel to do work. "Oh but it's so cool and smooth to see it glide while I select the rectangles" Choose a different career... art perhaps.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I agree with your @Mick! I opted out of this when I initially subscribed. I should NOT be forced to opt out again after an update or whatever. They really need to listen to the customer on this. There is a reason we opt out. Are they trying to force us to like this junk? It's distracting and terribly unnecessary. They can remove it and no one would notice.

  • Mick commented  ·   ·  Flag as inappropriate

    This is so distracting and annoying. It's like someone tapping you on the shoulder every five second while you try and think about something.

    This should be opt-in, not opt-out.

  • khalid commented  ·   ·  Flag as inappropriate

    im done with office, i never hated animation like this before, this is the first time an animated item manage to pesssss me off like this, going to cancel my subscription, bye bye have good day.

  • Apollo commented  ·   ·  Flag as inappropriate

    Is there also some way to turn off the animated dotted line around copied cells? Super distracting and annoying.

  • Kathy commented  ·   ·  Flag as inappropriate

    Ahhhh, thank you so much for the help that stopped that eye-crossing 'glide'! I just got this version of Excel and had no idea what to call it and could barely work with my large spreadsheets. I assumed it would be called something like 'cursor movement' and never would have chosen 'Provide feedback with animation' as a fix. What does that even mean?

  • Anonymous commented  ·   ·  Flag as inappropriate

    I hate the gliding as well. Have vision issues and is difficult to follow if it moves too quickly.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I'm using Window 7 and cancelled the animation successfully:
    Open Excel, File > Options > Ease Of Access > untick the box "Provide feedback with animation".

← Previous 1 3 4 5 24 25

Feedback and Knowledge Base