Feedback by UserVoice

How can we improve Excel for Mac?

Horizontal scroll is not working.

When I import a text file and want to select all of the columns as text the horizontal scroll feature does not work and I can only change what ever I can see in the window to text. I use the feature on a weekly basis. This makes excel 2016 unusable for me on a Mc.

41 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Bob North shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    Accepting Votes  ·  AdminExcel Team [MSFT] (Admin, Office.com) responded  · 

    By setting your scroll bars to be always shown in your MacOS general settings, you are able to scroll horizontally in the text import wizard.

    We will prioritize this issue accordingly with other issues based on the votes and interest that we see here.

    Steve K [MS Excel]

    12 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Darin commented  ·   ·  Flag as inappropriate

        This issue is so utterly annoying I can't even begin to explain my frustration. Please fis this.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Setting your scrollbars to "always" does at least allow you to get to the other columns.
        But you can only do so bar dragging the scrollbar thumb; you can't use your trackpad or mouse horizontal scroll gesture, or the keyboard.

      • CB commented  ·   ·  Flag as inappropriate

        This is a ridiculous setback for Excel 365 for Mac. Should be fixed. Bush league.

      • JB commented  ·   ·  Flag as inappropriate

        I agree and disagree Noel. You don't have to do that in Excel 2011. You only have to do it in 2016. What I said to do was simply a "workaround". Microsoft should adopt Apple's methodology and make the horizontal scrollbars to appear while scrolling. I hate having scrollbars always show and I will not set that option to always just for this one function.

      • Noel commented  ·   ·  Flag as inappropriate

        JB has hit the nail on the head. It's more of an Apple Scroll Bar issue than an Excel issue. Open 'System Preferences' either from your dock or from the Apple Menu (top left), select 'General', then next to the 'Show Scroll Bars' option select 'Always'. When you then open Excel and try and import a text file, the horizontal scroll bar is BACK!! This has frustrated me for 12 months and it now works.

      • JB commented  ·   ·  Flag as inappropriate

        Still an issue almost 2 years later. This works fine in Excel 2011 but does not in 2016. This is the one and only reason I still keep Excel 2011 on my Mac. In the community it was said that we should just turn on the option to have scrollbars always visible. I hate that option and while it does work, that is not a "fix". That is a workaround.

      • Lars commented  ·   ·  Flag as inappropriate

        This coulkd be related to "fixed columns". Can be deactivated in the Window Menu

      • Mike Crader commented  ·   ·  Flag as inappropriate

        I have reported this issue separately as one that involves both vertical scrolling through all records and horizontal scrolling to the end of all fields. These are available in the Windows version and are critical to being able to define a large fixed width field text data connection. Like others I am forced to use the Windows version. Incidentally, the macOS version connection properties check box to resize fields during a refresh refuses to stay unchecked after a properties edit. Again, the only way to get this done is in the Windows version. These issues have been around through many versions so I suspect they are not important enough to the developers to fix. Hopefully our comments here will convince them to revise that low priority.

      • Noel commented  ·   ·  Flag as inappropriate

        The horizontal scrolling on the Text Import Wizard Step 3 of 3 is also a major issue for me as I use it almost every day. At the moment I have to use an older version of Excel on a different Mac to import .txt files which means it is preventing me from upgrading my other Macs until this is resolved.

      • Myles commented  ·   ·  Flag as inappropriate

        Why is this is still a problem? Seems like it should have been sorted long ago.
        OP is referring to the "Text Import Wizard - Step 3 of 3", Curt_L you may have misunderstood.

        I also have numerous occasions when imported CSVs need to have text format forced upon them, it causes a lot of headaches and I have to find an available PC just to do this repetitive task.

      • Curt_L commented  ·   ·  Flag as inappropriate

        I experience this too. If I attempt to quickly scroll down a page, it often takes 2-3 tries before the screen finally recognized the scroll command.

      Feedback and Knowledge Base