Feedback by UserVoice

How can we improve Excel for Windows (Desktop Application)?

Don't autocorrect if you can't override (idiotic functionality keeps changing EHR to HER, but you can't undo like in Word or Outlook).

Get smart like iOS on your autocorrect. If you a user deletes/overrides your autocorrection right away, leave it alone. The way the feature is implemented in Excel leaves the user no choice but to turn it off.

Try it. Type EHR (as in Electronic Health Record) into a cell (with our without the leading single quote and watch it autocorrect to HER when you hit return or select another cell. Undo does not work (like it does in Word or Outlook).

1 vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    VL shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  AdminExcel Team [MSFT] (Admin, Office.com) responded  · 

    We have good news to share. In the January 2019 release of Excel for both Mac and Windows, this issue has been resolved. Once you install the update, Excel will allow you to override any autocorrection simply by going back and typing over the correction. For example, if you type “HSA” into cell A1, Excel will autocorrect it to “HAS”. If you go back and type “HSA” again in the same place, Excel will not correct it again. It will still autocorrect “HSA” if you type it into a different location, or if another autocorrection happens before you change “HAS” back to “HSA”. To summarize, Excel will no longer make the same autocorrection 2 times consecutively.

    This fix is included in Excel for Mac if you have version 16.20 or greater, and Excel for Windows if you have version 16.0.11126 or greater.

    1 comment

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Yes, I hate this feature. Can't figure out how to turn it off. When you type "turn off autocorrect" into the "Tell me what you want to do" search box, you get no results. Amazing

      Feedback and Knowledge Base