Feedback by UserVoice

How can we improve Excel for Windows (Desktop Application)?

removing sexist algorithms

Please can you allow "Mrs. and Mr." to be written in excel without excel autocorrecting to "Mrs. And Mr." because the traditional rules state that the man is first. I am writing letters to donors and I always put the donor in the first position and the associated donor in the second. Excel only auto capitalizes the "and" when it is in the Mrs. and Mr. position. This is a pain that it was written into the algorithm. And sexist. Thanks.

1 vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
completed  ·  AdminExcel Team [MSFT] (Product Owner, Office.com) responded  · 

We have good news to share. In the January 2019 release of Excel for both Mac and Windows, this issue has been resolved. Once you install the update, Excel will allow you to override any autocorrection simply by going back and typing over the correction. For example, if you type “Mrs. and Mr.” into cell A1, Excel will autocorrect it to “Mrs. And Mr.”. If you go back and type “and” again in the same place, Excel will not correct it again. It will still autocorrect “Mrs. And” if you type it into a different location, or if another autocorrection happens before you change “And” back to “and”. To summarize, Excel will no longer make the same autocorrection 2 times consecutively.

This fix is included in Excel for Mac if you have version 16.20 or greater, and Excel for Windows if you have version 16.0.11126 or greater.

8 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • SC commented  ·   ·  Flag as inappropriate

    Nope, not already supported. That's a half-baked workaround at best, not support.

  • Huzaifa commented  ·   ·  Flag as inappropriate

    Thanks for sharing the workaround. Is this going to be logged as a Bug for future fix or we always use the workaround ?

  • ElderWand commented  ·   ·  Flag as inappropriate

    Yeah, these are not a fix:

    Add “Mrs.” to the list of exceptions by these steps:
    1. In Word, type “Mrs. and Mr.” and after it capitalizes “And”, backspace and fix it so that it’s lowercase “and”. This will add “Mrs.” as an exception so that the next word you type will no longer by capitalized.
    2. Quit Word and restart Excel.

    or
    1. In Excel or Word, go to File > Options > Proofing > AutoCorrect Options… > Exceptions.
    2. Type “mrs.” in the text field and click “Add”.
    3. Click Ok, Ok, Ok.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Or... They could just change the algorithm that does not automatically capitalize the 'and' in Mr. and Mrs. but does capitalize it when it is Mrs. and Mr.
    That would be the best solution. They are basically perpetuating the idea that the man always goes first. Why can't whatever they programmed in for 'Mr. and Mrs.' also be applied to 'Mrs. and Mr.'? No sentence has ever ended with Mrs. and we all know it is correct to start a sentence with 'And'. They obviously allowed for the rule for one direction but not the other.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I'd suggest that the easiest way is to use open punctuation and stop putting a full stop after Mrs and after Mr. It's become a bit outmoded to do so in most formal letters anyway. And that will stop the capitalisation afterwards.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I was the original poster. The answer was so offensive and what made it worse was that they see nothing wrong with having to take all these steps to fix their algorithm. Very sexist algorithm. Microsoft - get your act together.

  • Anonymous commented  ·   ·  Flag as inappropriate

    We should not need to go through multiple cumbersome steps to remove a sexist algorithm that exists within Excel. Fix it.

Feedback and Knowledge Base