Feedback by UserVoice

How can we improve Excel for Windows (Desktop Application)?

removing sexist algorithms

Please can you allow "Mrs. and Mr." to be written in excel without excel autocorrecting to "Mrs. And Mr." because the traditional rules state that the man is first. I am writing letters to donors and I always put the donor in the first position and the associated donor in the second. Excel only auto capitalizes the "and" when it is in the Mrs. and Mr. position. This is a pain that it was written into the algorithm. And sexist. Thanks.

1 vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    You are able to set the rules for when Office should not change the first letter of a sentence to a capital. You can add to the list of abbreviations which should behave as exceptions to the option “Capitalize first letter of sentences”.

    Add “Mrs.” to the list of exceptions by these steps:
    1. In Word, type “Mrs. and Mr.” and after it capitalizes “And”, backspace and fix it so that it’s lowercase “and”. This will add “Mrs.” as an exception so that the next word you type will no longer by capitalized.
    2. Quit Word and restart Excel.

    or
    1. In Excel or Word, go to File > Options > Proofing > AutoCorrect Options… > Exceptions.
    2. Type “mrs.” in the text field and click “Add”.
    3. Click Ok, Ok, Ok.

    7 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Huzaifa commented  ·   ·  Flag as inappropriate

        Thanks for sharing the workaround. Is this going to be logged as a Bug for future fix or we always use the workaround ?

      • ElderWand commented  ·   ·  Flag as inappropriate

        Yeah, these are not a fix:

        Add “Mrs.” to the list of exceptions by these steps:
        1. In Word, type “Mrs. and Mr.” and after it capitalizes “And”, backspace and fix it so that it’s lowercase “and”. This will add “Mrs.” as an exception so that the next word you type will no longer by capitalized.
        2. Quit Word and restart Excel.

        or
        1. In Excel or Word, go to File > Options > Proofing > AutoCorrect Options… > Exceptions.
        2. Type “mrs.” in the text field and click “Add”.
        3. Click Ok, Ok, Ok.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Or... They could just change the algorithm that does not automatically capitalize the 'and' in Mr. and Mrs. but does capitalize it when it is Mrs. and Mr.
        That would be the best solution. They are basically perpetuating the idea that the man always goes first. Why can't whatever they programmed in for 'Mr. and Mrs.' also be applied to 'Mrs. and Mr.'? No sentence has ever ended with Mrs. and we all know it is correct to start a sentence with 'And'. They obviously allowed for the rule for one direction but not the other.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I'd suggest that the easiest way is to use open punctuation and stop putting a full stop after Mrs and after Mr. It's become a bit outmoded to do so in most formal letters anyway. And that will stop the capitalisation afterwards.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I was the original poster. The answer was so offensive and what made it worse was that they see nothing wrong with having to take all these steps to fix their algorithm. Very sexist algorithm. Microsoft - get your act together.

      • Anonymous commented  ·   ·  Flag as inappropriate

        We should not need to go through multiple cumbersome steps to remove a sexist algorithm that exists within Excel. Fix it.

      Feedback and Knowledge Base