Feedback by UserVoice

How can we improve Excel for Windows (Desktop Application)?

Make Excel obey the "scroll inactive windows" setting in Windows 10

Make Excel obey the "scroll inactive windows" setting in Windows 10. Currently Excel will scroll when it is an inactive window, but it will not allow other windows to scroll when it is the active window. This makes transcribing data from a source that needs to be scrolled difficult.

97 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Randy shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
completed  ·  AdminExcel Team [MSFT] (Product Owner, Office.com) responded  · 

Thanx for creating and voting on this folks!

You should see this issue fixed starting with the latest Windows 10 Preview 17133.73 build update on 4/10 (https://blogs.windows.com/windowsexperience/2018/03/27/announcing-windows-10-insider-preview-build-17133-for-fast/) as well as latest Excel Monthly channel 1803 Build 9126.2152 update on 4/11 (https://technet.microsoft.com/en-us/office/mt465751.aspx).

Please let us know if you find this still not fixed with these builds (and later).

thanx,
Prash [MSFT]

62 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Loren Amelang commented  ·   ·  Flag as inappropriate

    My Excel 2016 MSO is a paid-once version, and was (finally) fixed yesterday. That update "just worked", but in the past I've had a horrible time getting paid Excel to update. I believe some parts of the update system cannot cope if you _ever_ use a "metered connection". I've seen the update files for at least five new versions queued in the update folder but they won't install. Worse, it kept re-downloading them, over the metered connection, and failing to install each time! Seemed like spending a full day connected to a non-metered connection was the only escape from that. Like yesterday...

  • Anonymous commented  ·   ·  Flag as inappropriate

    I can confirm that this issue is fixed BUT everyone should note that you do need to have both a newer version of 32 bit Office AND a newer version of Windows 10 to benefit. If you type WINVER at the run command you are looking for Windows OS Build of 17133.72 or greater and if you open Excel you need to go to File/Account/About Excel and you are looking for version 16.0.9126.2152 32 bit or greater.

    I think you only see the later versions of Office if you are on 365. Anyone not "renting" from MS will be ignored as worthless.

  • Loren Amelang commented  ·   ·  Flag as inappropriate

    Just received Excel 2016 MSO (16.0.11126.20192) 32-bit, on Win 10 Pro 1803, 17134.523.

    All hover scrolling tests work properly, among multiple open Excel windows and other app windows! Thank you for persisting... At least my combination finally works.

  • Dimitri commented  ·   ·  Flag as inappropriate

    Excel 2016 x64 on Windows 10 x64, Version 1809, works just fine.
    With Excel open (either active or inactive), all other open windows scroll as they should, if the "Scroll inactive windows when I hover over them" setting has been enabled.

    Problem seems to have been FIXED!

  • Adonal Arrington II commented  ·   ·  Flag as inappropriate

    I can confirm that the fix only works when using one excel window, if you have multiple excel windows open, inactive scrolling does not work between the two excel windows. So this issue is "half" fixed but still a long ways to go. I am using the latest Office 365 Enterprise and Windows 10 version 1803.

    C'mon Microsoft, get it together....

  • ktc commented  ·   ·  Flag as inappropriate

    Just installed Office 2019 on Win10 home 10.0.16299 build 16299 and any active Excel window hijacks the scroll wheel so it cannot be used on inactive windows, and the scroll wheel has no effect on inactive Excel windows.

    Really, how hard can this be?

  • Mike Lee commented  ·   ·  Flag as inappropriate

    excel 2013 (15.0.5075.1000) MSO (15.0.5075.1001) 32-bit
    win 10 pro version 1803 (OS Build 17134.345)

    any two windows that aren't excel, inactive scrolling works as expected
    two windows, one of which is excel:
    excel window has focus, excel scrolls no matter which window the mouse pointer is over
    other window has focus, nothing happens (neither window scrolls) when hovering over the excel window

    it was much better when it worked correctly.

  • Alfredo commented  ·   ·  Flag as inappropriate

    This WAS fixed for a while, but a recent (sometime around Aug/Sep 2018) Office (or possibly Windows) update broke it again. How can MS keep making this same mistake? Only effects Excel, not Word or any other parts of Office (at least of the ones I use).

    Currently, the status is as follows:

    Word in one window, anything (including Word) in the other window: ok.

    Excel in one window, anything other than Excel in the other window: ok.
    Excel in both windows: Only active window will scroll.

  • Loren Amelang commented  ·   ·  Flag as inappropriate

    The "fix" supposedly needs Windows 17133.73 and Excel 9126.2152. I have 17134.285 (64-bit) and 10730-20102 (installed in 32-bit mode), and I still have the behavior described by PH_CH back in May.

    One Excel window mixed with other windows scrolls properly. But a second Excel window "below" the working one acts like part of the top Excel instance - scrolling with the cursor there scrolls the topmost Excel window.

    I spend a lot of time working with multiple Excel windows. Having to bring each one to the top to scroll it is a frustrating waste of energy.

    To get this fixed we need to be very specific which problems we are seeing! "It still doesn't work" is totally ignored by the developers. Is anyone with new enough versions still seeing other scroll issues?

  • Jeff commented  ·   ·  Flag as inappropriate

    Does this affect both 32 and 64 bit versions of Excel? we are running 32-bit

  • Jeff commented  ·   ·  Flag as inappropriate

    still not fixed. how hard is this. it works for every other MS product just not Excel. I have all updates for office and for windows 1803 and it is still broken. I am not sure how this is taking so long.

  • PH_CH commented  ·   ·  Flag as inappropriate

    I could test an *Excel 2o16* installation and noticed the following:

    Excel and other programs: no more problems.
    Two Excel windows: scrolling in the inactive Excel window is not possible, no reaction. Behavior as if the mouse were still in the first Excel window. Other programs: normal behavior.

    So I have to say that Excel 2016 does not bring any improvement in scrolling behavior to me!
    Excel 2013 together with WizMouse behave exactly the same!

  • PH_CH commented  ·   ·  Flag as inappropriate

    *** Slowly I should think about switching to Apple! ***

    Sorry, the bug exists since October 2016 and Micro$oft was not capable to solve this problem, yet.

    May be they should ask the producer of *WizMouse* how to solve this problem!
    Unfortunately, the tool does not work with 2 open Excel windows, so I need a complete solution.

    And finally I won't upgrade to Office 2016/365 and throw money at Microsoft for doing nothing.

← Previous 1 3 4

Feedback and Knowledge Base