Feedback by UserVoice

How can we improve Excel for Windows (Desktop Application)?

Data Labels disappearing from charts

This is a real problem !! When you refresh a picot chart the Data Labels either totally go away or some of them do... It's inconsistent .

This same problem was inherited by the Web version btw.

7 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

6 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Tom commented  ·   ·  Flag as inappropriate

    Hi Guys
    I have the same problem. I use cells to provide data for all data labels on the chart. When I save the file, close it and reopen, my labels are gone. I mean they there but contain nothing, as if something emptied them. The only thing that helps is to delete them and recreate.
    My workaround is to use macro which refills all data labels with text every time an action happens in the cells used by the chart. Looks kinda like this (only part of it):

    Dim ChangeSeries As Series
    Dim m_cht As Chart

    Set m_cht = Worksheets("Tracker").ChartObjects("Chart 9").Chart
    Set ChangeSeries = m_cht.SeriesCollection(2)

    With ChangeSeries.Points(1)
    .HasDataLabel = True
    .DataLabel.Text = Sheet1.Range("Q12").Value
    End With

    With ChangeSeries.Points(2)
    .HasDataLabel = True
    .DataLabel.Text = Sheet1.Range("Q13").Value
    End With

  • Anonymous commented  ·   ·  Flag as inappropriate

    When I update the chart with data labels and change the filter the data labels disappear. I tried to do this in different ways but of no use. Can anyone help me with this problem?

  • Angela commented  ·   ·  Flag as inappropriate

    One used to be able to copy charts and past as a picture in another document. Now the Series Labels are changed from the correct labels to Series 1, Series 2, etc. What gives?

  • Tommy commented  ·   ·  Flag as inappropriate

    I am having this problem with a dynamic named range. Series data labels disappear after criteria has changed.

  • Daniel commented  ·   ·  Flag as inappropriate

    I am constantly having this issue as well for what its worth (with the desktop version, I don't use the web version).

Feedback and Knowledge Base